Puch M 125 - Not starting after engine overhaul

This Forum is for Puch Motorcycle related topics.
Post Reply
ADP91
Posts: 6
Joined: Sat May 16, 2015 2:24 pm

Puch M 125 - Not starting after engine overhaul

Post by ADP91 » Sat May 16, 2020 6:17 pm

Hi all,

I rebuilt my 1968 Puch M 125 a few years back (new crankseals, gaskets, etc) but never got around to firing it up. I have it all back together, there is good compression, spark, and the carb is all cleaned up but.. its not starting.

Any tips or suggestions for non-starting? Could ignition timing be off after I put the cases back together?

Any advice is appreciated!

Thanks
-A
olpuchguy
Posts: 182
Joined: Fri Oct 31, 2014 8:13 pm

Re: Puch M 125 - Not starting after engine overhaul

Post by olpuchguy » Sun May 17, 2020 11:02 am

Some years ago I redid the cylinder/rings on a 50cc Wards Riverside...and I installed the piston backwards. It wouldn't start. Could that be your problem? (Probably not. But thought I'd mention it.)
1969 SR125 sold
1964 150A sold
1965 150A sold
1958 175 Standard
1960 125 Hardtail
1980 Puch Magnum II
1960 Sears Allstate 123.94401 (Yardman Motorette) sold
1960(?) Sears Allstate 1233.94400 (Yardman Motorette) sold
1958 Sears 811.30 scooter sold
Clintonhill
Posts: 7
Joined: Tue Mar 31, 2020 8:10 am

Re: Puch M 125 - Not starting after engine overhaul

Post by Clintonhill » Mon Jun 29, 2020 12:19 pm

My 175svs did not start after I rebuilt the engine,with a lot of head scratching I realised the piston was at the bottom of the stroke I rechecked the timing with a flat screwdriver through the bottom hole and aligned the end to the notch in the flywheel and readjusted the points and and checked the piston was at the top stroke this time which it was then she ran,I don’t know how I missed the notch so next time I will set timing before I fit barrel so I can see where the piston is ,hope this helps sorry about delay as my iPad keeps playing up
Post Reply