Puch 250 runs for a short while only

This Forum is for Puch Motorcycle related topics.
Post Reply
aermacchirich
Posts:6
Joined:Tue Mar 08, 2016 8:08 pm
Puch 250 runs for a short while only

Post by aermacchirich » Sun Aug 04, 2019 3:34 pm

Hi Guys. Hope someone can help me on a 1968 250 Puch. It will start and run for about 15 seconds before the carburetor spits and the bike stops. Giving it any throttle whatsoever will stall the bike. When the bike is running it is not running strong but just kind of stumbles along.

This bike ran well before I did some work on it as follows:

I replaced the armature. The bike had a fluctuating voltage across the battery terminals (using a digital voltmeter) of between 6 and 18 volts. The regulator was replaced with a new one from Motor West and mounted in the tool box. In the short time I had the bike running with the new armature it appears that this fluctuating problem has not been solved. I tested the field coils on the generator years ago and they seemed fine.

The bike was timed and I checked this several times. The lobe on the armature just breaks the points with the flywheel set with a small punch in the timing mark. Spark plugs are good and have been checked. Armature was "flashed".

Bike is getting gasoline and the carburetor was cleaned.

Ant advice on the charging problem would be appreciated but I am more concerned about getting the bike running well again. Fuel or electrical ? That is the question.

Thanks in advance - Rich
aermacchirich
Posts:6
Joined:Tue Mar 08, 2016 8:08 pm

Re: Puch 250 runs for a short while only

Post by aermacchirich » Mon Aug 05, 2019 11:55 am

I took a look at this again and the motor is turning in the wrong direction. Took it up the street and tried to start in gear but no go. Wondering if any one has seen this problem before. When I kick start it , it starts but catches at the very end and turns the motor the wrong way. It will only run for about 10 seconds.
bocutter
Posts:275
Joined:Wed Apr 13, 2011 12:33 pm
Location:Toronto (Leaside), Canada

Re: Puch 250 runs for a short while only

Post by bocutter » Mon Aug 05, 2019 12:21 pm

aermacchirich wrote:
Mon Aug 05, 2019 11:55 am
I took a look at this again and the motor is turning in the wrong direction. Took it up the street and tried to start in gear but no go. Wondering if any one has seen this problem before. When I kick start it , it starts but catches at the very end and turns the motor the wrong way. It will only run for about 10 seconds.
Never heard of that. Did you set the timing with the motor/armature turning counterclockwise ?
'61 Puch DS60 (Allstate Compact) - sno-bike
'66 Puch 250 SGS - off the bench Aug '19
'87 BMW K75s - daily user

My name is Ed
aermacchirich
Posts:6
Joined:Tue Mar 08, 2016 8:08 pm

Re: Puch 250 runs for a short while only

Post by aermacchirich » Mon Aug 05, 2019 12:59 pm

Yes I did set it counter clockwise. Just headed to the garage now to recheck.
bocutter
Posts:275
Joined:Wed Apr 13, 2011 12:33 pm
Location:Toronto (Leaside), Canada

Re: Puch 250 runs for a short while only

Post by bocutter » Mon Aug 05, 2019 1:51 pm

Ok, so you want the points to open on the down side of the cam (open circuit is points just touching, not points just opening).
'61 Puch DS60 (Allstate Compact) - sno-bike
'66 Puch 250 SGS - off the bench Aug '19
'87 BMW K75s - daily user

My name is Ed
aermacchirich
Posts:6
Joined:Tue Mar 08, 2016 8:08 pm

Re: Puch 250 runs for a short while only

Post by aermacchirich » Mon Aug 05, 2019 2:23 pm

Hi Ed. Rechecked the timing again and I was WAAAY off. Fixed that up and bike is now running like a champ. My charging problem was also fixed with the new armature. In a hurry now to get this bike on the road as they are real chick magnets. Thanks again for your help. Regards, Rich
bocutter
Posts:275
Joined:Wed Apr 13, 2011 12:33 pm
Location:Toronto (Leaside), Canada

Re: Puch 250 runs for a short while only

Post by bocutter » Mon Aug 05, 2019 3:08 pm

Fortunately I have fresh experience having just refreshed the seals in my '66. It's alive after 6 years on the workshop mezzanine. 😁
'61 Puch DS60 (Allstate Compact) - sno-bike
'66 Puch 250 SGS - off the bench Aug '19
'87 BMW K75s - daily user

My name is Ed
Post Reply